Unclean uninstall - Event Viewer errors

Post here if you have problems installing or using doPDF.
Posts: 3
Joined: Mon Jan 16, 2012 4:52 pm

Postby occam » Tue Jan 17, 2012 12:09 am


I was running doPDF on my Win 7 Sp1 for a while (dopdf5, doPDF6, doPDF7)

I recently uninstalled the latest doPDF, and discovered that I have two 'Event Viewer' (administrative event errors) remaining from previous doPDF5 and doPDF6 installs which I cannot shake off:

1- (regarding doPDF5) The print spooler failed to load a plug-in module dopdfmn5.dll, error code 0x7e. See the event user data for context information.

2-(regarding doPDF6) Printer doPDF v6,0 failed to initialize because a suitable doPDF 6 Printer Driver driver could not be found. The new printer settings that you specified have not taken effect. Install or reinstall the printer driver. You might need to contact the vendor for an updated driver.

I have already tried the 'completely uninstall-procedure' under the FAQ here


It has not got rid of the problem.

I have also tried re-installing and uninstalling these two with RevoUninstall. Again, the two errors persist. (They are errors not Warnings or Information points)

Any pointers? How can I get rid of these? I realise they may not be detremental to the operation of my portable, but I have by now become obsessed by them :-)


unclean uninstall, event errors, printer spooler

Claudiu (Softland)
Posts: 1495
Joined: Thu May 23, 2013 7:19 am

Postby Claudiu (Softland) » Tue Jan 17, 2012 2:00 pm


Please install and uninstall each of the versions again by using our uninstaller from the add remove programs. Also make sure you restart your computer after each uninstallation. There may have been some leftovers either in the registry or the printer drivers.

So typically install v5 from http://www.dopdf.com/download/setup/dopdf-5.exe , restart the pc, then uninstall it and restart the PC again. After that install v6 from http://www.dopdf.com/download/setup/dopdf-6.exe , restart , uninstall it and restart again.

Eventually after all this is over you can also search for any remaining files using the link you specified in the previous post.

Posts: 3
Joined: Mon Jan 16, 2012 4:52 pm

Postby occam » Tue Jan 17, 2012 6:15 pm

I have already been through this cycle twice. I re-installed doPDF5, rebooted, made sure the Event error had disappeared, then I uninstalled it - first with the built-in uninstaller, and on a second round with Revo-Uninstaller (set at its most aggressive mode).

Alas, after each cycle, the Event error has re-appeared soon after uninstall.

(I did the same two cycles with doPDF6 also.)

In both cases the Event error disappeared after install, but re-appeared after uninstall.

I am baffled!

Claudiu (Softland)
Posts: 1495
Joined: Thu May 23, 2013 7:19 am

Postby Claudiu (Softland) » Fri Jan 20, 2012 2:43 pm


We have tried to replicate the issues but both our tested versions uninstalled successfully. What we can suggest related tothe novaPDF 5 version error is for you to go to the registry path HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\ , find the novaPDF 5 entry and remove it from there.

Regarding novaPDF 6 there is also a registry key you need to find and remove but that one depends on the OS so it would be the best to just search the registry editor for any novapdf 6 values and remove those. Additionally, go to the Devices and printers area, click on any of the printers, click on the Print server properties button , go to drivers and remove the dopdf 6 value if present.

If this does not work either then there must be some other applications installed that use the printers one way or another and prevented them from uninstalling so an accurate test case for troubleshooting cannot be made from here unfortunately.

Thank you.

Posts: 3
Joined: Mon Jan 16, 2012 4:52 pm

Postby occam » Mon Jan 23, 2012 2:04 am

Worked! Thanks

- (doPDF 5) HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\ (as recommended)

- (doPDF 6) HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Printers\ (deleted doPDF v6 registry folder)

error messages no longer there, after a couple of reboots.

Thanks again

Return to “Troubleshooting”