Page 1 of 1

Posted: Thu Jan 07, 2010 1:16 am
by fastoy

I'm running XP Pro SP3, Firefox 3.5.7 and doPDF 7. On a fresh instance of Firefox, I can print successfully to a (network) printer. Then I print to doPDF. Subsequent prints to the real printer result in nothing, not even an error. Other applications, e.g. IE7, don't have this problem. Printing starts working again after a Firefox restart but the missing prints never appear.


Posted: Fri Jan 08, 2010 1:30 pm
by Claudiu (Softland)

Sounds a bit strange, because at least an error should be returned. When the network printer isn't responding, does printing to dopdf still works? Trying to figure out if printerspooler crashes or not. Also, have you installed any unusual firefox plugins? You might want to test starting it in safe mode (all plugins disabled) just in case something doesn't work the way it's supposed to work.

Posted: Fri Jan 08, 2010 10:18 pm
by fastoy

doPDF still works. I just print to PDF and print the PDF. Restarting Firefox restores the printing capability. I'll try Firefox in safe mode. Hadn't thought of add-ins.

Posted: Wed Jan 20, 2010 1:53 am
by fastoy

I tried this with Firefox in safe mode with the same results. The first print attempt after starting in safe mode I printed to a networked printer. Worked. The second print attempt went to doPDF and worked. The third print attempt I directed back to the networked printer and nothing happened.

I'm now running Firefox 3.6b5.

Not that it should matter as this also happens in safe mode but here's a list of my add-ons:

Posted: Thu Jan 21, 2010 12:49 pm
by Claudiu (Softland)

Sorry but I'm not sure what the problem is, and I couldn't reproduce it. It does seem that something is wrong with the printspooler, so see if there is a newer version of the driver for the networked printer.

Posted: Fri Jan 22, 2010 8:20 pm
by fastoy

Thanks for testing this for me. I'll look for a newer driver.

If this is a problem with the printspooler, wouldn't it persist? The symptom disappears when I restart Firefox.

I think this may be a Firefox problem. It doesn't happen with IE.

Posted: Mon Jan 25, 2010 2:10 pm
by Claudiu (Softland)

if it would be a problem with the print spooler then the problem would persist until the service is restarted (or if it crashes and is restarted automatically). as you say you restart only firefox maybe this isn't the issue - however do you know how to look at your Windows Event Logs to see if there are any warning/errors in there that point to a printer driver?

Posted: Wed Jun 02, 2010 12:32 pm
by walked

I am having the same problem with printing. I have tried Firefox, Chrome, IE, and Safari and I can't print from any of them. I would love to know if anyone has a solution as I am the tech for a school district and I have a lot of teachers who are starting to use Google docs instead of MS Word.

Posted: Wed Jun 02, 2010 12:49 pm
by Claudiu (Softland)

@walked, you've posted previously that dopdf wasn't showing in the list of printers, so did you manage to install it but now you cannot print through it?