Page 1 of 1

Cannot Install doPDF 8.0.910

Posted: Sat Jun 28, 2014 12:31 am
by DERoss
Windows 7 (x64)
Full installer file dopdf-full.exe, modified Wednesday, ‎June ‎25, ‎2014, ‏‎6:05:03 AM, version 8.0.910.0

Yes, I know there are other topics with this subject.

I could not install doPDF 8.0.910 because I had not uninstalled doPDF 8.0.907. Attempts to uninstall doPDF 8.0.907 repeatedly failed. Contrary to replies in other forum topics, the failure window did NOT have an OK button. The only buttons were Try Again and Close. Attempts to uninstall novaPDF, however, all succeeded -- according to Windows; but all novaPDF components reappeared. This was almost like a game of Whack-a-Mole, but this is serious and not a game.

In desperation, removed doPDF from my list of printers. Next, I located all instances of doPDF, novaPDF, and Softland on my hard drives, deleting all except the new installer, logs, and files of E-mail message about doPDF. Then, I purged my registry of references to doPDF, novaPDF, and Softland, finding many references to doPDF 7 when my current (old version) was doPDF 8. All this finally eliminated novaPDF from the list in Window's Programs and Features window.

I then tried again to install doPDF 8.0.910. This time, there was no complaint about needing to uninstall a prior version. However, the installation hung at about 87%, looking for related applications. This left a partial installation of doPDF, which I was able to uninstall. It also left novaPDF add-ins for Office, which reappear as soon as they are uninstalled. (Whack-a-Mole again!!)

CONCLUSION: doPDF itself is an excellent application. Installing it, however, is user-hostile. I was a software test engineer for 30+ years, working on complex systems for operating a multitude of different earth-orbiting, military space satellites. Effectively, my job involved intense quality control in which we had to use the software in realistic situations before we would permit it to be installed by the U.S. Department of Defense. I can tell from my experience -- both my career and my attempts to install doPDF -- that grossly insufficient testing (if any) was performed on the latter.

Re: Cannot Install doPDF 8.0.910

Posted: Sat Jun 28, 2014 3:14 am
by DERoss
I tried installing doPDF 8.0.910 via the stub installer. It hung at 75% with "Rolling back action:". Yes, there was a colon at the end of "action".

The Cancel button for the full and the stub installers is non-functional.

I tried reverting back to doPDF 8.0.907, but I could not install it successfully. I kept getting error popups regarding a printer (i.e., "The arguments are invalid" and something about a print driver missing.) When I tried to uninstall the partially installed doPDF 8.0.907, I kept getting "Failed to uninstall. Please try again. Fatal error during installation." Note the "installation" at the end of the message. In that case, retrying repeated the error; but the Cancel button actually worked.

I was finally able to revert all the way back to doPDF 7.3.398. Fortunately, I archive the installer files for applications on my PC, which is why I initially tried to use the full installer file dopdf-full.exe: I don't want to encounter a situation where a stub installer is requesting to download a file that no longer exists.

I now have a good installation of doPDF 7.3.398 AND a bad installation of doPDF 8.0.907.

Re: Cannot Install doPDF 8.0.910

Posted: Mon Jul 07, 2014 9:04 am
by Claudiu
Sorry for this, the main problem right now during installation is that we rely on .NET and if something is not right on that computer all sorts of problems show up.
Given your experience we could really use your help in troubleshooting this. so (once again) could you please email us the latest log files from your TEMP folder but this time to Thank you.

P.S. I know we're already discussing via the support email too.

Re: Cannot Install doPDF 8.0.910

Posted: Mon Jul 07, 2014 10:50 pm
by DERoss
My current situation is as follows:

I scanned all files on my C-drive for Softland, doPDF, and novaPDF, removing any for version 8. I then scanned my registry for those same three terms and deleted all keys, values, and data for version 8. Only in that manner was I able to remove a partial, failed installation of doPDF 8. In the process, I deleted all the associated log files.

However, I previously (27 June) sent the log files to In a reply from, I was advised to change some registry entries under HKEY_LOCAL_MACHINE\SOFTWEARE\Softland\novaPDF8 in order to remove doPDF 8 successfully. THAT DID NOT HELP.

I archived the E-mail message to your info address, and the sent log files are still attached to it. I will resend that message to your support address shortly.

I have downloaded the complete (not stub) installer for doPDF 8.0.911. I do NOT plan to attempt an installation until I get some assurance that the effort will be successful.

Re: Cannot Install doPDF 8.0.910

Posted: Wed Aug 06, 2014 11:35 pm
by DERoss
I consider this issue CLOSED since I have now reported in a new topic my unsuccessful attempt to install doPDF 8.0.915.