Page 1 of 1

Posted: Wed Mar 11, 2009 6:53 pm
by DocW

Greetings,


I have both CS 3 and Reader 8 installed. When I use doPDF, the resulting file opens in Acrobat instead of Reader despite the fact that I have my system set to open .PDF files with Reader (Acrobat and the other components of CS3 take much longer to load).


Can you please advise how I can get the files created by doPDF to open in Reader rather than Acrobat?



Posted: Thu Mar 12, 2009 11:09 am
by Softland

Probably you installed CS3 after reader, and it associated the pdf extension with cs3. Try right-clicking and selecting Open With for a pdf, and mark "always use this program to open this type of document" (or something similar it says for that option) and see if that works. If not I would recommend installing the newest version of Adobe Reader and maybe it will associate pdf by default with it.



Posted: Fri Mar 13, 2009 3:36 am
by Melvin

Hi DocW,


I had a similar problem, and found a solution for Windows XP. First, I'll tell you my solution, and then I'll describe how I came up with that solution.


1) The solution is to modify your registry, specifically ...


HKEY_CLASSES_ROOT \ AcroExch.Document.7 \ shell \ Open \ command


... to point to your Reader application, instead of Acrobat.


For example, I changed the entry to the following (I'm using Reader 9.1):


[HKEY_CLASSES_ROOT\AcroExch.Document.7\shell\Open\command]

@="\"C:\\Program Files\\Adobe\\Reader 9.0\\Reader\\AcroRd32.exe\" \"%1\""


If you're using Reader 8.0, then you'll need to change the directory path of course, and you should verify your actual path since it could be different.


NOTE (an alternative workaround): Before I made this mod, I could also open Reader first before printing, and the document created by doPDF would be opened in Reader instead of Acrobat.


2) How did I know this? I used Sysinternals' Process Monitor to watch what doPDF is doing within the guts of Windows during a print, and this registry value is one that doPDF is accessing on my computer to determine which application to open.


I don't know if my fix will work on your machine, but I think it'd be worth a try. If it doesn't, you might try Process Monitor to see if your machine is using a different registry key to determine which app to launch.


WARNING: Please be sure to backup your registry, or at least export HKEY_CLASSES_ROOT\AcroExch.Document.7 before modifying this key. With this key exported to a file before you make this mod, you'll have the ability to restore the registry to it's previous value.


Hope this helps!

Melvin


P.S. I had tried changing the .pdf file association, but it didn't make any difference. Plus, I have a really old version of Acrobat, and have installed and updated Reader many times since Acrobat was installed. Finally, the AcroExch.Document.7 key is not accessible through the Window's File Types.



Posted: Fri Mar 13, 2009 2:56 pm
by Softland

Excellent tutorial Melvin, I moved it to the Tutorials section.