Since downloading DOPDF file my laptop will not print any Doc's

Post here if you have problems installing or using doPDF.
Posts: 1
Joined: Wed Dec 17, 2008 9:07 pm

Postby hkosberg » Thu Dec 18, 2008 4:17 am

I downloaded DoPdf and the files convert to PDF.

however, now my laptop will not print to any of my printers either connected directly to my hp color laser jet 2600n or thru my wireless network.

when i open my printers and faxes file and click on properties on my hp2600n, i get a message that the print spooler service is not running.

if i try to do a normal print of a word doc to my printer i now get a message that says the printer is not set up. i can remove and reload the hp 2600n but it will not correct the problem. seems the DoPdf download did something to my other print drivers?

Posts: 2
Joined: Wed Dec 24, 2008 4:25 pm

Postby capy12 » Wed Dec 24, 2008 11:32 pm

I am having this same problem except that my print spooler service is running (I even restarted the service with no change). I recently purchased a new computer and I used doPDF on my old Windows XP system without any problems so I decided to install it on my new one. My new system uses Vista, so I wonder if there's a compatibility issue. I print over a network with no success after installing doPDF. Also, I do not get any error messages, I print, it sends, but nothing comes out of the printer. Any suggestions would be welcome. In the mean time, I will uninstall doPDF and see what happens. Thanks.

Posts: 2
Joined: Wed Dec 24, 2008 4:25 pm

Postby capy12 » Thu Dec 25, 2008 12:37 am

I found a way to fix the problem if you are using Vista, like I was. Apparently, because I am using an older printer, there indeed was a compatibility issue with Vista and it had nothing to do with doPDF. Here's the solution that worked for me:

Installing a Network Printer in Vista:

1) Hard wire the printer to the Vista "client" PC or laptop, as though it were to be used with that computer, and install it. This ensures that it has all the necessary software/drivers on board. (This step is important for this fix to work)

2) Reconnect it to the "host" PC and, in its Properties, set it as "shared". Make a note of both the host PC's "Computer Name" and the printer's "Share Name".

3) In the Vista "client" PC, launch the "Add a Printer" wizard and select the "Add a local printer" option. This automatically opens a new dialog box in which to select the Port.

4) Click the "Create a new port" radio button and leave the drop-down menu options on the default of "Local Port". Click Next.

5) A small box opens in which to enter the Port Name. Type in the path to the "shared" printer in the host PC using the format \\computername\sharename where computername and sharename are the details you noted in (2) above.

6) Select the Printer driver from the list provided, which should include the driver you originally installed, otherwise use the "Have Disk" button to install the correct Vista driver if it is not in the list. It is essential that a Vista-compatible driver for your printer is used. Click Next. If you get a dialog box that tells you "Windows detected that a driver is already installed for this printer", click "Replace the current driver"

7) Give the printer a name and choose whether to set it as the default. Click Next.

8) Print a test page to verify functionality and then click Finish.

Claudiu (Softland)
Posts: 1492
Joined: Thu May 23, 2013 7:19 am

Postby Claudiu (Softland) » Mon Jan 05, 2009 2:10 pm


If it still didn't work after a restart, you should start the print spooler service (and make sure is set to automatic start, not manual) as instructed here -


Glad you found the solution

Posts: 2
Joined: Mon Jul 27, 2009 3:45 pm

Postby careyaj » Mon Jul 27, 2009 10:52 pm

Capy's solution did work for me. I tried so many things (restart, re-install the printer). Interestingly, I could no longer access my printer as a TCP/IP printer, which I have been able to before - even with dopdf installed (so I'm not sure that it's just vista). Just wanted to mention, that you do not necessarily need to plug in the printer to your latop (client pc) - mine didn't recognize that it was connected so I continued without the connection and it was still completely installed and worked fine.

FYI I am using an everex laptop, vista 32bit, samsung clx printer.

Posts: 2
Joined: Mon Jul 27, 2009 3:45 pm

Postby careyaj » Sat Aug 15, 2009 11:04 pm

I have a new computer with the same problem (now a gateway, vista 64-bit, samsung clx3160 printer. I tried many work-arounds (including removing dopdf and doing a system restore to the point before any printers were installed), and while the one above does work, I didn't want to be dependant on another computer to print. I found that when I went to Printer settings - for me found when I click the taskbar icon - that shows the toner levels etc (this takes you to http ://(networkprinter's IP address)/ (then clicked network settings, and IP filtering) - I found what the problem is - somehow IP filtering is now turned on since installing dopdf and my computer is not allowed. I could add my computer, but since we have rotating IPs that would not be a permanent solution so we switched off IP filtering. If you have Static IPs and would like this filter on make sure your computer's IP address is there. I don't know if this applies to anyone else, but since it solved my problem I thought I'd share!

Return to “Troubleshooting”