IE7 printing errors

Post here if you have problems installing or using doPDF.
Post Reply
anon
Posts: 38
Joined: Tue Jun 03, 2008 8:42 am

Post by anon »

I use IE7/Vista Home Basic (x86, ITA, SP1). Fully updated (SP1 included).

If I print the about:Tabs or the res ://C:\Program%20Files\IEPro\IEProRs.dll/easyhome.html (a virtual page with thumbs of preferred URLs thanks to the plugin IE7Pro, just like Opera browser) the PNG are not transparent and/or missing.

Please can you check this out?
Ciao!


Claudiu (Softland)
Posts: 1506
Joined: Thu May 23, 2013 7:19 am

Post by Claudiu (Softland) »

doPDF should print the webpages exactly the way they look in Print Preview, so if a webpage looks bad in Print Preview it's because the way that page's html is written and the way the browser interprets that.
Go to Tools->Internet Options->Advanced->Printing and see if the "Print background colors and images" option is checked. This might have been the problem in your case as I printed that page and the images were there (though the page looked a little weird on their side).


anon
Posts: 38
Joined: Tue Jun 03, 2008 8:42 am

Post by anon »

Already tried.

Print Preview shows correct rendering, but final printing with doPDF is different showing non-transparent PNG (quick test URL "about:Tabs").


Claudiu (Softland)
Posts: 1506
Joined: Thu May 23, 2013 7:19 am

Post by Claudiu (Softland) »

I see what you mean now. Go to Start->Settings->Printers and Faxes, right-click on doPDF and select Properties. Go to the Advanced tab and in there uncheck the option Enable advanced printing features and press ok after that. Try converting the about:Tabs page now, the png should be printed correctly.


anon
Posts: 38
Joined: Tue Jun 03, 2008 8:42 am

Post by anon »

Thanks it prints much better now but there is still a flaw: the buttons, listers etc. in the WEB page get printed with a ugly black background instead of transparent.

As a test you can use also this forum web page.


Claudiu (Softland)
Posts: 1506
Joined: Thu May 23, 2013 7:19 am

Post by Claudiu (Softland) »

I just double-checked:

- with the option Enable advanced printing features unchecked, this page prints correctly (with the transparent background)

- with the option Enable advanced printing features checked, this page prints incorrectly (with the transparent background converted to black)
So make sure you unchecked that option when you try it.


anon
Posts: 38
Joined: Tue Jun 03, 2008 8:42 am

Post by anon »

Of course.

I've done a shot to show you my problem:
I use Vista Home Basic (SP1, x86) with Desktop Compostion on (color scheme "Vista Standard" I don't have Aero).


Claudiu (Softland)
Posts: 1506
Joined: Thu May 23, 2013 7:19 am

Post by Claudiu (Softland) »

I've reproduced this now too. I don't have a solution for this, but what's strange is that on my side using IE7 under Windows XP some of the buttons have black backgrounds, but if I use Maxthon2 (which uses the same IE printing core) it prints correctly.
We'll look into this. Thank you.


anon
Posts: 38
Joined: Tue Jun 03, 2008 8:42 am

Post by anon »

Ok, and thank you for dedicated support! :)


Post Reply