doPDF does not appear in the printers list after installation

Post here if you have problems installing or using doPDF.
Claudiu (Softland)
Posts: 1495
Joined: Thu May 23, 2013 7:19 am

Postby Claudiu (Softland) » Wed May 28, 2008 5:24 pm

After you install doPDF it is recommended to restart your computer if the final window of the installation wizard tells you so. If doPDF does not appear in your Printers and Faxes list after installation (or you get Printer not installed when trying to create PDFs), it means something went wrong with the installation.

One of the possible reasons the installation failed is due to the fact that the Windows printer installer looks for the file framedyn.dll in the system path and does not find it (Microsoft shows solutions for that here too - Microsoft Knowledge Base Article 319114). This DLL is supposed to be located under a wbem directory in system32 and the system path is supposed to point to that directory.

However it seems that under some installations, the system path contains a space character after the wbem directory or before it, which prevents Windows XP from finding this DLL, or in the Environment Variables the path to this directory is different than the one on your hard drive.


  1. Go to Start->Programs->doPDF 6 and select Uninstall doPDF 6

  2. Check to see if the path of that dll is c:\windows\system32\wbem with a space after wbem (or before it). If this is the case, please remove it and try reinstalling doPDF

  3. If that space isn't in there, copy the framedyn.dll file to the c:\windows\system32\ directory and reinstall doPDF after that.

  4. If that doesn't work either, go to Start->Settings->Control Panel->System->Environment Variables, in the System Variables select Path and click on Edit. See if the path containing wbem (%SystemRoot%\System32\Wbem by default) has the first letters of the system32 and wbem folders the same case as the path on your hard drive, if not change them in this variable to match those of the hard drive. For example if on your hard drive the path is C:\WINDOWS\system32\wbem but in the system variable mentioned above it appears as %SystemRoot%\System32\Wbem, you will have to change the latter to read %SystemRoot%\system32\wbem (notice the small caps). Reinstall doPDF after that.

Since doPDF supports logged installation, these are some other errors shown in the log file when the installation fails due to the reason above:

FAILED to install driver: "doPDF 6 Printer Driver" Error = 126

did not add "doPDF 6 Monitor" port monitor. Error = 3006

FAILED to install printer: "doPDF v6" Error = 1797

Posts: 1
Joined: Tue Aug 05, 2008 9:35 pm

Postby raudawg » Wed Aug 06, 2008 4:48 am

When I download the installer, I first tried choosing the "run" option. After the download was complete, nothing ran. So I re-downloaded it and saved the file to my desktop. The file name is dopdf.1.2D0D17. I have the computer set to suppress file extensions, so I've looked at the file type, and it says it's an EFW file. When I double-click on the file icon, nothing happens. I've tried right-clicking and choosing "Open". Nothing happens.

What am I supposed to do with this thing? I need this piece of software.

Claudiu (Softland)
Posts: 1495
Joined: Thu May 23, 2013 7:19 am

Postby Claudiu (Softland) » Wed Aug 06, 2008 9:52 am

the file you download should be named dopdf.exe without any other digits/characters - I'm not sure what you downloaded but that doesn't seem to be the setup. I suggest you download it directly from here: and after that double-click it to start the installation.

By the way, where did you download that file in the first place so I could check it out?

Posts: 1
Joined: Mon Aug 24, 2009 7:38 pm

Postby fiveofakind » Tue Aug 25, 2009 2:39 am

thanks, this fixed it!

Posts: 2
Joined: Tue May 04, 2010 12:37 pm

Postby lagodfrey » Tue May 04, 2010 8:03 pm

I was using version 6 of DoPDF for along time and then finally updated to version 7 and now I can't get it to show up under my printers. All my other printers work fine. I have tried all of the above mentioned suggestions but it still will not show up under printers. After uninstalling and reinstalling a number of times it did show up under prints for a brief time, 30 seconds, and then disappeared. Also when I have it installed and go to Settings and bring up the Printer and Faxes window, the window stalls for a period of 20 to 30 seconds before it will finally show my printers, but no DoPDF. If you have any other suggestions I can try I would appreciate it.

Posts: 5
Joined: Tue Aug 11, 2009 1:47 pm

Postby bernardfeltzer » Wed May 05, 2010 11:13 pm

I haven't had any problems installing in Win7 64.

In Vista 32bit OS, I downloaded dopdf to desktop, installed, would not work, didn't show up in printers.

What I have been doingto get it to install properly on vista is download to desktop, install, restart computer, sign in, press the dopdf install program again, this time it takes a little longer, restart computer.

After doing all that, it works for me.

Posts: 2
Joined: Tue May 04, 2010 12:37 pm

Postby lagodfrey » Fri May 07, 2010 12:04 am

I am using windows XP with all of the latest updates and service packs. I tried what bernardfeltzer suggested with no success. I have even went into the registry and searched for all references to Softland and DoPDF and deleted them then reinstalled DoPDF again. Also searched through my C: drive and deleted all references, shut down and restarted print spooler and still nothing. Very frustrating as I need this program badly.

Posts: 1
Joined: Fri May 14, 2010 12:32 pm

Postby jhoward » Fri May 14, 2010 7:38 pm

I also had problems getting the installation to complete without any errors. I would get a "failed to install driver" error 126. I tried the fixes already mentioned in this thread but was still having problems.

The problem was that the file srclient.dll was missing in my system32 folder. Once I copied the file to that location the installation worked perfectly.

Question for Softland: Does the installation program try and create a restore point during installation?

Claudiu (Softland)
Posts: 1495
Joined: Thu May 23, 2013 7:19 am

Postby Claudiu (Softland) » Mon May 17, 2010 4:37 pm

@jhoward, thanks for the tip regarding srclient.dll, if others will have problems we'll suggest that too.

dopdf doesn't create a restore point during install/uninstall, however when we'll release a package that uses Windows Installer it will create this (probably in the next major version)

Posts: 5
Joined: Thu May 27, 2010 6:39 am

Postby walked » Wed Jun 02, 2010 12:23 pm

I'm having the same problem with PromoPDF (and now doPDF, too!) . The WBEM appaers to have the correct name (no blanks) and I have copied the framedyn DLL to my windows/system32/wbem folder. I then uninstalled and reinstalled, and still no primoPDF in my Printers List.

I then thought I'd check the MS fix, and the link went to "Error Message: "Access Is Denied" When You Try to Open NTFS File System Folders" solution.

Could you confirm the link please?

Return to “Troubleshooting”