Unchecking Open PDF in Reader option doesn't prevent opening!

You can ask general questions, share opinions or advices about doPDF.
magic144
Posts: 8
Joined: Fri Feb 18, 2011 2:29 am

Postby magic144 » Fri Feb 18, 2011 9:33 am

Using 0.7.2.359

Windows 7 Home Premium 32-bit


Even with the option cleared/unchecked, after "printing" the file is IMMEDIATELY opened in Adobe Reader


Hints/answers for this?

Otherwise, looks good.

Cheers...



Softland
Posts: 1497
Joined: Thu May 23, 2013 7:19 am

Postby Softland » Fri Feb 18, 2011 1:44 pm

Hello,


We tried to replicate the issue but the option worked as expected on all the prints that have been done.


Can you please let us know from what application are you doing the printing?


Thank you.



magic144
Posts: 8
Joined: Fri Feb 18, 2011 2:29 am

Postby magic144 » Fri Feb 18, 2011 2:30 pm

ie9 rc

not sure why the version of browser should make a difference?!



Softland
Posts: 1497
Joined: Thu May 23, 2013 7:19 am

Postby Softland » Fri Feb 18, 2011 3:39 pm

Hello,


We tried the internet explorer but could not replicate the behavior.


If you are printing from Notepad for example are you getting the same results?


Thank you.



magic144
Posts: 8
Joined: Fri Feb 18, 2011 2:29 am

Postby magic144 » Fri Feb 18, 2011 6:12 pm

Hmm, that's weird


from Notepad, there seems to be an independent set of print settings for doPDF

the "Open in PDF Reader" setting from there seems to control how ie9 rc1 behaves, even though ie9 rc1 presents a different/independent setting [same property sheet, just a separate setting]


also ie9 rc1 opens a DOS box when printing - this is not evident when printing from Notepad.


perhaps there's some kind of context switching when printing from ie9 rc due to Protected Mode? where are these settings stored?



magic144
Posts: 8
Joined: Fri Feb 18, 2011 2:29 am

Postby magic144 » Fri Feb 18, 2011 6:17 pm

specifically, where is the setting "Open in PDF Reader" stored?



magic144
Posts: 8
Joined: Fri Feb 18, 2011 2:29 am

Postby magic144 » Fri Feb 18, 2011 6:38 pm

right

ie9 rc seems to use THIS file when presenting its print driver settings...

C:\Users\User\AppData\Local\Microsoft\Windows\Temporary Internet Files\Virtualized\C\Users\User\AppData\Roaming\Softland\novaPDF\doPDF v7.nvl


notepad seems to use THIS file

C:\Users\User\AppData\Roaming\Softland\novaPDF\doPDF v7.nvl


in BOTH cases, setting from the LATTER seem to take effect at the time of actual printing...



magic144
Posts: 8
Joined: Fri Feb 18, 2011 2:29 am

Postby magic144 » Sat Feb 19, 2011 6:19 am

This page describes how and why Protected Mode is doing what it's doing...


http://msdn.microsoft.com/en-us/library/bb250462(v=vs.85).aspx


doPDF needs to take this into account!



Softland
Posts: 1497
Joined: Thu May 23, 2013 7:19 am

Postby Softland » Mon Feb 21, 2011 1:16 pm

Hello,


We have taken this issue into consideration for further troubleshooting and correction.


Thank you for pointing out this change to us.



Softland
Posts: 1497
Joined: Thu May 23, 2013 7:19 am

Postby Softland » Mon Feb 21, 2011 8:31 pm

We studied the problem but unfortunately we do not have a technical solution. doPDF settings are kept in the "Application Data" for the current user, as you noticed. But when Internet Explorer runs in "protected mode" and the UAC is enabled, Internet explorer is restricted to write in this folder. doPDF printer driver is loaded by Internet Explorer and runs in its context, so the options cannot be saved in this case.

doPDF settings will be taken into account if you start Internet Explorer with the "Run As Administrator" option or if you disable UAC (User Account Control settings), and also disable "Protected mode" in the Internet Explorer Security settings.

This way from our tests, the print is made successfully with the settings taken into consideration from the doPDF Save As dialog.


Thank you.




Return to “General”